We have many happy clients using the code canyon NMI plug in for WooCommerce. This has proven to be a great solution for WooCommerce merchants who want or need to features available in NMI such as multi merchant account balancing, and I-Spy fraud detection, especially high risk merchants. As of the writing of this blog post the NMI plug-in for WooCommerce appears to only be compatible with Woocommerce 2.4, 2.3, 2.2 or 2.1. Users currently running 2.5 may receive inconsistent results or error messages.  We expect clients to get notification of an update from the helpful folks at code canyon soon but in the interim merchants could simply stick with 2.4. Here is a helpful thread from WordPress.org on rolling back WooCommerce to a previous version https://wordpress.org/support/topic/revert-back-to-previous-version.

If you have any questions, regardless of whether you are a client or not, please feel free to drop us a line, we are always happy to help. If you are really in a bind feel free to use our rapid reply request form